Tutorial Cara Install Mikrotik CHR pada Server dengan CentOS 7


Mikrotik seringkali diperlukan untuk mengelola sebuah network secara fisik atau virtual. Dulu, Mikrotik diinstal pada perangkat secara fisik, tapi saat ini sudah ada Mikrotik CHR (Cloud Hosted Router) bisa diinstal di mana pun pada VPS yang kamu miliki. Di artikel ini, kamu akan mempelajari cara install Mikrotik CHR pada VPS dengan sistem operasi CentOS 7.

Apa Itu Mikrotik CHR?

Mikrotik Cloud Hosted Router atau disingkat Mikrotik CHR adalah versi RouterOS yang didesain khusus agar sebuah perangkat komputer dapat dijalankan secara virtual di Virtual Machine (VM). CHR menggunakan arsitektur x86 64-bit dan bisa digunakan pada sebagian besar hypervisor, seperti VMWare, HyperV, atau VirtualBox.

Mikrotik CHR sama seperti RouterOS biasanya, kecuali level lisensinya. Tapi tenang saja, kita tetap bisa menggunakan CHR dengan lisensi gratis, walaupun kecepatan traffic dengan lisensi gratis hanya akan dibatas pada 1 Mbit per interface.

Baca Juga: Perintah Dasar Linux untuk Pemula

Cara Install Mikrotik CHR pada CentOS 7

Berikut ini kamu akan mempelajari cara install Mikrotik CHR untuk server dengan sistem operasi CentOS 7. Tapi sebelum itu, pastikan kamu sudah menyiapkan beberapa hal berikut:

Langkah instalasi:

  • Update Server
  • Install Firewall
  • Download Mikrotik CHR
  • Mount Mikrotik CHR
  • Download Winbox
  • Testing

Berikut ini adalah penjabaran dari langkah instalasi di atas.

Update Server

Pertama, kamu perlu memiliki server yang sudah diperbarui agar package-nya juga ikut diperbarui. Setelah itu, lakukan reboot server.

 

$ yum update -y

$ reboot

 

Install Firewall

Firewall yang akan digunakan pada cara install Mikrotik di CentOS 7 ini adalah CSF (ConfigServer Security & Firewall).

 

$ cd /usr/src

$ wget https://download.configserver.com/csf.tgz 

$ tar -xzf csf.tgz

$ csf csf/

$ install.sh

Edit csf.conf lalu ubah value make TESTING menjadi 0.

 

$ nano /etc/csf/csf.conf

make TESTING=’0’

 

Jika sudah, simpan lalu keluar. Kemudian reload CSF dengan perintah berikut:

$ csf -r

 

Download Mikrotik CHR

Install beberapa package yang dibutuhkan di CentOS 7 untuk keperluan cara instalasi Mikrotik CHR, lalu unduh package Mikrotik CHR dengan pilihan Raw Disk Image pada versi 6.47.6 (stable).

$ yum install wget unzip -y

$ wget https://download.mikrotik.com/routeros/6.47.6/chr-6.47.6.img.zip -O mik-chr.img.zip

 

Perintah di atas berarti melakukan wget file chr-6.47.6.img.zip yang kemudian disimpan dengan nama mik-chr.img.zip. Lalu unzip file .zip yang sudah diunduh sebelumnya dan coba list.

$ unzip mik-chr.img.zip

$ ls

chr-6.47.6.img  mik-chr.img.zip

 

Mount Mikrotik CHR

Mount berkas chr-xxxx ke direktori /mnt dengan perintah di bawah ini.

$ mount -o loop,offset=512 chr-xxx /mnt

 

Verifikasi hasil mount tersebut dengan perintah:

$ ls /mnt

bin  boot  dev  lost+found  nova  rw  SHOW_LICENSE  UPGRADED  var

 

Kemudian buat sejumlah perintah pada CLI untuk mengatur addressing dari alamat IP pada interface ether1, default route, dan server DNS dari Mikrotik CHR yang dapat dieksekusi dengan perintah echo. Selanjutnya perintah tersebut akan disimpan dalam berkas autorun.scr yang terdapat pada direktori /mnt/rw/. Perintahnya seperti di bawah ini.

$ ADDRESS=`ip addr show eth0 | grep global | cut -d' ' -f 6 | head -n 1` && 

GATEWAY=`ip route list | grep default | cut -d' ' -f 3` && 

echo "/ip address add address=$ADDRESS interface=[/interface ethernet find where name=ether1]

/ip route add gateway=$GATEWAY

/ip dns set servers=8.8.8.8,8.8.4.4" > /mnt/rw/autorun.scr

 

Pastikan apakah perintah-perintah tersebut sudah tertulis di dalam file autorun.scr atau belum.

$ cat /mnt/rw/autorun.scr

/ip address add address=103.xxx interface=[/interface ethernet find where name=ether1] 

/ip route add gateway=103.xxx

/ip dns set servers=8.8.8.8,8.8.4.4

 

Pada bagian address=103.xxx, angka ini akan sesuai dengan alamat IP di VPS kamu. Setelah proses mounting sudah selesai, maka kamu bisa melepas mount (unmout) dengan perintah:

$ echo u > /proc/sysrq-trigger

 

Lalu salin seluruh isi dan file dari images chr tadi ke direktori /dev/vda menggunakan perintah dd (disk dump) seperti di bawah ini.

$ dd if=chr-6.47.6.img bs=1024 of=/dev/vda

 

Maka output-nya akan keluar seperti ini:

5536+0 records in 

65536+0 records out 

67108864 bytes (67 MB) copied, 4.85649 s, 13.8 MB/s

 

Sesuaikan versi Mikrotik CHR dengan berkas yang sudah diunduh menggunakan perintah wget tadi. Kemudian reboot VPS menggunakan perintah reboot.

$ reboot

 

Baca Juga: Cara Flush DNS pada Windows, Mac, dan Linux

Open Console

Mikrotik CHR tidak dapat disambungkan ke SSH dengan cara manual dari command prompt maupun terminal, maka hal ini perlu dilakukan dari Console Client Area di provider VPS kamu. Misalnya di kalau di Dewaweb akan terlihat seperti:

Client Area -> Manage Services -> Pilih Server/VPSnya -> Open Console.

Secara default, Mikrotik menggunakan username Admin dan password-nya dikosongkan (atau langsung klik Enter saja).

cara install mikrotik chr routeros di centos 7

Download Winbox

Jika sudah reboot, VPS akan memulai kembali secara otomatis. Proses selanjutnya adalah kamu perlu mengunduh software atau aplikasi Winbox. Winbox adalah software atau aplikasi untuk mengadakan koneksi ke mikrotik.

Testing

Jika sudah diunduh, buka Winbox dan isi formulir yang ada sesuai dengan informasi yang kamu miliki.

fill form mikrotik chr

Connect To: (masukkan IP Address VPS kamu)

Login: admin

Password: (kosongkan)

Kamu bisa mengosongkan bagian kata sandi, karena secara default Mikrotik tidak menggunakan password, melainkan hanya username untuk login saja.

Setelah selesai diisi, klik “Connect”. Jika koneksi berhasil, maka tampilannya akan seperti ini.

install mikrotik chr testing selesai berhasil

Jika sudah seperti di atas, maka kamu sudah berhasil melakukan cara install Mikrotik CHR pada CentOS 7 sudah selesai.

Baca Juga: Cara Melakukan Speedtest Server di CentOS 7

Simpulan

Mikrotik CHR sama seperti Mikrotik RouterOS pada umumnya, yang biasa diinstal di perangkat secara langsung sedangkan CHR diinstal secara virtual pada server VPS. Namun, ketika memilih VPS, pastikan kamu menggunakan layanan yang terpercaya, misalnya Dewaweb. Selain karena selalu bisa diandalkan, kecepatan dan keamanan yang kamu dapatkan tak lagi menjadi masalah.

Demikian artikel tutorial cara install Mikrotik CHR di CentOS 7 ini, jangan sungkan untuk meninggalkan ide-ide topik yang ingin kamu baca di blog Dewaweb. Semoga artikel ini membantu!





Sumber

Related Articles

LEAVE A REPLY

Please enter your comment!
Please enter your name here

Stay Connected

21,594FansLike
0FollowersFollow
0SubscribersSubscribe
- Advertisement -

Latest Articles