Tutorial Cara Install Mikrotik CHR pada Server dengan CentOS 8


Mikrotik seringkali diperlukan ketika mengelola sebuah network secara fisik atau virtual. Saat ini, Mikrotik tersedia dalam versi cloud yang bernama Mikrotik CHR. Sistem operasi ini memungkinkan kamu untuk bisa menginstal Mikrotik CHR pada VPS atau server yang kamu miliki. Di artikel ini, kamu akan mempelajari bagaimana cara meng-install Mikrotik CHR di CentOS 8.

Mikrotik CHR

Mikrotik Cloud Hosted Router atau disingkat Mikrotik CHR adalah versi RouterOS yang didesain khusus agar sebuah perangkat komputer dapat dijalankan secara virtual di Virtual Machine (VM). CHR menggunakan arsitektur x86 64-bit dan bisa digunakan pada sebagian besar hypervisor, seperti VMWare, HyperV, atau VirtualBox.

Mikrotik CHR sama seperti RouterOS biasanya, kecuali level lisensinya. Tapi tenang saja, kita tetap bisa menggunakan CHR dengan lisensi gratis, walaupun kecepatan traffic dengan lisensi gratis hanya akan dibatas pada 1 Mbit per interface.

Baca Juga: Cara Instalasi VirtualBox di CentOS 7

Cara Install Mikrotik CHR di CentOS 8

Berikut ini adalah cara install Mikrotik CHR untuk VPS dengan sistem operasi CentOS 7. Tapi sebelum itu, pastikan kamu sudah menyiapkan beberapa hal berikut:

Langkah instalasi:

  • Update Server
  • Install Firewall
  • Download Mikrotik CHR
  • Mount Mikrotik CHR
  • Download Winbox
  • Testing

Berikut ini adalah penjelasan dari langkah instalasi di atas.

Update Server

Pertama, pastikan terlebih dulu apakah server sudah diperbarui, tujuannya adalah agar package yang akan digunakan ikut diperbarui juga. Kemudian lakukan reboot server.

$ yum update -y

$ reboot

 

Install Firewall

Firewall yang digunakan dalam cara install Mikrotik di CentOS 8 ini adalah CSF (ConfigServer Security & Firewall). Instalasi CSF Firewall di CentOS 8 sedikit berbeda dengan OS lain.

$ cd /usr/src

$ wget https://download.configserver.com/csf.tgz 

$ tar -xzf csf.tgz

 

Install & Create directory iptables

$ yum install iptables-services -y

$ touch /etc/sysconfig/iptables

$ touch /etc/sysconfig/iptables6

 

Install CSF

$ csf csf/

$ install.sh

$ perl /usr/local/csf/bin/csftest.pl

 

Edit csf.conf lalu ubah value make TESTING menjadi 0.

 

$ nano /etc/csf/csf.conf

make TESTING=’0’

 

Setelah itu simpan dan keluar. Kemudian, reload CSF dengan perintah berikut.

$ csf -r

 

Download Mikrotik CHR

Install beberapa package yang dibutuhkan untuk keperluan instalasi Mikrotik CHR di CentOS 8 ini, kemudian unduh package Mikrotik CHR dengan pilihan Raw Disk Image, di sini kami menggunakan versi yang sudah stabil, yaitu v6.47.6.

$ yum install wget unzip -y

$ wget https://download.mikrotik.com/routeros/6.47.6/chr-6.47.6.img.zip -O mik-chr.img.zip

 

Perintah di atas berarti kamu akan mengunduh menggunakan wget dan menyimpannya dengan nama mik-chr-.img.zip. Jika sudah terunduh, unzip atau extract file .zip tersebut dan list.

$ unzip mik-chr.img.zip

$  ls 

chr-6.47.6.img  mik-chr.img.zip

 

Artinya proses unzip sudah selesai.

Mount Mikrotik CHR

Lakukan mount pada file chr-xxxx.img ke direktori /mnt dengan perintah di bawah ini.

$ mount -o loop,offset=512 chr-xxxx.img /mnt

 

Sesuaikan nama “xxxx” dengan file CHR yang kamu miliki. Kemudian, verifikasikan hasil mount yang dilakukan tadi dengan perintah berikut ini.

$ ls /mnt

bin  boot  dev  lost+found  nova  rw  SHOW_LICENSE  UPGRADED  var

 

Setelah itu, buat sejumlah perintah pada CLI untuk mengatur addressing dari alamat IP pada interface ether1, default route, dan server DNS dari Mikrotik CHR yang dapat dieksekusi dengan perintah echo. Kemudian sejumlah perintah tersebut akan disimpan dalam file autorun.scr yang terdapat pada direktori /mnt/rw/. Perintahnya akan terlihat seperti di bawah ini.

$ ADDRESS=`ip addr show eth0 | grep global | cut -d' ' -f 6 | head -n 1` && 

GATEWAY=`ip route list | grep default | cut -d' ' -f 3` && 

echo "/ip address add address=$ADDRESS interface=[/interface ethernet find where name=ether1]

/ip route add gateway=$GATEWAY

/ip dns set servers=8.8.8.8,8.8.4.4" > /mnt/rw/autorun.scr

 

Verifikasikan apakah perintah-perintah tersebut sudah tertulis di dalam file autorun.scr atau belum.

$ cat /mnt/rw/autorun.scr

/ip address add address=103.xxx interface=[/interface ethernet find where name=ether1] 

/ip route add gateway=103.xxx

/ip dns set servers=8.8.8.8,8.8.4.4

 

Bagian address=103.xxx ini nantinya akan sesuai dengan alamat IP di VPS kamu. Mengingat proses mounting sudah selesai, maka kamu bisa melepas mount (unmout) dengan perintah:

$ echo u > /proc/sysrq-trigger

 

Kemudian salin seluruh isi dan berkas dari images chr tadi ke /dev/vda menggunakan perintah dd (disk dump) seperti di bawah ini.

$ dd if=chr-6.47.6.img bs=1024 of=/dev/vda

65536+0 records in

65536+0 records out

67108864 bytes (67 MB, 64 MiB) copied, 4.20313 s, 16.0 MB/s

 

Sesuaikan versi CHR dengan file yang kamu unduh tadi menggunakan perintah wget. Kemudian reboot VPS menggunakan perintah reboot.

$ reboot

 

Open Console

Kamu tidak dapat menghubungkan Mikrotik dengan SSH secara manual dari command prompt maupun terminal. Jadi kamu memerlukan Console Client Area di provider VPS kamu. Misalnya di Dewaweb, langkahnya akan seperti berikut ini:

Client Area -> Manage Services -> Pilih Server/VPS-nya -> Open Console.

Secara default, Mikrotik menggunakan username Admin dan password-nya dikosongkan (atau langsung klik Enter saja).

Gambar di atas menunjukkan bahwa Mikrotik CHR sudah berhasil ter-install di VPS. Selanjutnya kamu bisa membuat koneksi menggunakan aplikasi Winbox.

Download Winbox

Usai reboot, VPS akan memulai kembali secara otomatis. Proses selanjutnya adalah kamu perlu mengunduh software atau aplikasi Winbox, yaitu software atau aplikasi untuk melakukan koneksi ke Mikrotik.

Baca Juga: Cara Install Moodle di VPS Ubuntu 18.04

Testing

Jika sudah terunduh, buka Winbox dan isi datanya sesuai dengan keperluanmu:

Connect To: (masukkan IP Address VPS kamu)

Login: admin

Password: (kosongkan)

Kamu bisa mengosongkan bagian password, karena secara default Mikrotik tidak menggunakan password, melainkan hanya username untuk login saja. Setelah selesai, klik “Connect” dan tampilannya akan seperti gambar di bawah ini.

install mikrotik chr testing success

Jika tampilannya sudah seperti di atas, maka cara install Mikrotik CHR pada CentOS 8 sudah selesai.

Baca Juga: Cara Install Moodle di VPS CentOS 7

Simpulan

Mikrotik CHR sama seperti Mikrotik RouterOS pada umumnya, hanya saja CHR tidak di-install langsung di sisi perangkat komputer, melainkan secara virtual di server VPS dengan cara seperti di atas. Setelah disambungkan, kamu perlu mengubah aturannya sesuai kebutuhanmu, terlebih di bagian bagian informasi login yang bisa memengaruhi keamanan koneksi internetmu.

Namun, satu hal yang perlu kamu ingat, ketika memilih VPS, pastikan kamu menggunakan layanan yang terpercaya, misalnya Dewaweb. Selain karena selalu bisa diandalkan, kecepatan dan keamanan yang kamu dapatkan tak lagi menjadi masalah. Demikian artikel tentang cara install Mikrotik CHR di CentOS 8 ini. Semoga artikel ini membantu, salam sukses online!





Sumber

Related Articles

LEAVE A REPLY

Please enter your comment!
Please enter your name here

Stay Connected

21,590FansLike
0FollowersFollow
0SubscribersSubscribe
- Advertisement -

Latest Articles